ProTeacher Community - Reply to Topic




Home Join Now Search My Favorites
Help


Post Your Reply!

btmn's Message:

Does anyone know if there is a fuse on the promethean projectors.
I'm the site tech, and we had a power interruption with the boards outlet. Got that fixed, but now the board is on (green light on "standby" switch) however there is no power to projector. No lights of any kind! Connections appear good...any ideas?

Members have more posting options! Sign Up Free!
Random Teacher Question
Name:
Type a guest name (or sign up for a free account)
Descriptive Title (Please do type a title):
  
Message:

Additional Options
Not a member? See the great features you're missing
Did you know? ProTeacher is a FREE service

Discussion Review (newest messages first)
eatrunteach 03-12-2017 06:49 AM

Mine did something similar. The filter was totally clogged. I blew it out with a hair dryer and also blew out the unit itself. TONS of dust bunniesmflew out all over my classroom, but the projector worked after that.

btmn 11-28-2015 07:45 PM

Tried just about everything, unplugged, restart cpu, unplugged all connections, but nothing worked.
However, district tech guys came in and fixed, but I don't know what they did to fix it.
Thanks anyway!

chanrowl 11-24-2015 05:18 PM

It's an enigma to me, but a very intriguing one! So, just trying to help rule out things, what have you tried so far (i.e. unplugged it/plugged it in)?

btmn 11-07-2015 06:53 PM

Does anyone know if there is a fuse on the promethean projectors.
I'm the site tech, and we had a power interruption with the boards outlet. Got that fixed, but now the board is on (green light on "standby" switch) however there is no power to projector. No lights of any kind! Connections appear good...any ideas?




Sign Up Now

Sign Up FREE | ProTeacher Help | BusyBoard

All times are GMT -8. The time now is 06:01 PM.

Copyright © 2019 ProTeacher®
For individual use only. Do not copy, reproduce or transmit.
source: www.proteacher.net