ProTeacher Community

ProTeacher Community (http://www.proteacher.net/discussions/index.php)
-   Smartboarders (http://www.proteacher.net/discussions/forumdisplay.php?f=63)
-   -   Promethean Projector Fuse??? (http://www.proteacher.net/discussions/showthread.php?t=544520)

btmn 11-07-2015 06:53 PM

Promethean Projector Fuse???
 
Does anyone know if there is a fuse on the promethean projectors.
I'm the site tech, and we had a power interruption with the boards outlet. Got that fixed, but now the board is on (green light on "standby" switch) however there is no power to projector. No lights of any kind! Connections appear good...any ideas?

chanrowl 11-24-2015 05:18 PM

What have you tried?
 
It's an enigma to me, but a very intriguing one! So, just trying to help rule out things, what have you tried so far (i.e. unplugged it/plugged it in)?

btmn 11-28-2015 07:45 PM

Still an enigma!
 
Tried just about everything, unplugged, restart cpu, unplugged all connections, but nothing worked.
However, district tech guys came in and fixed, but I don't know what they did to fix it.
Thanks anyway!

eatrunteach 03-12-2017 06:49 AM

Clean the filter?
 
Mine did something similar. The filter was totally clogged. I blew it out with a hair dryer and also blew out the unit itself. TONS of dust bunniesmflew out all over my classroom, but the projector worked after that.


All times are GMT -8. The time now is 09:50 PM.

Copyright © ProTeacher®
For individual use only. Do not copy, reproduce or transmit.
source: www.proteacher.net